DREHSCHEIBE-Online 

Anzeige

HIER KLICKEN!

 11 - Bahn und Medien 

  Neu bei Drehscheibe Online? Hier registrieren! Zum Ausprobieren und Üben bitte das Test-Forum aufsuchen!
Software, Medien aller Art und Literatur zum Themengebiet Eisenbahn
Moderatoren: Klaus Habermann - MWD

Seiten: 1 ... 5 6 7 8 9 10 11 12 13 14 15

Angemeldet: -

Re: Flickr-Bilder

geschrieben von: Sören Heise

Datum: 19.12.17 13:10

Hallo Michael.

Michael Ulbricht schrieb:
Wenn man den BB-Code von Flickr unter teilen verwendet, wird es korrekt angezeigt ...
Der BB-Code von Flickr hat keine Leerzeile. [www.drehscheibe-online.de] hat Leerzeilen.

Ich nehme nochmal ein Bild von mir. Aha. Ich baue nach dem Bildlink einen manuellen Zeilenwechsel ein. Das sieht sonst nämlich vielleicht doof aus auf größeren Schirmen, wenn da Text neben dem Bild steht. Oder wie hier in der Vorschau, die anders aussieht als wie das Original:

Doof.jpg


Und die Software weiß also, dass die bei Bildlinks zu Flickr da automatisch eine Leerzeile einbauen muss, wenn da sowas wie

BSW01 by Sören Heise, auf Flickr

fehlt. Hm.

Aber: In [www.drehscheibe-online.de] habe ich unten hinter ------------ zwei Leerzeilen drin. Da baut der Editor drei. Im Nicht-BB-Code-Editor ist der Befehl zum Schließen in einer separaten Zeile, was er faktisch nicht ist. Der entsprechende Öffnen-Befehl ist dort auch in einer separaten Zeile, was aber keine Auswirkungen am Beitragsbeginn hat.

Wäre das nicht vielleicht einfacher und auch im Sinne mancher Nutzer, wenn man den Editor wieder standardmäßig auf BB-Code umstellt?

Viele Grüße
Sören





1-mal bearbeitet. Zuletzt am 2017:12:19:13:10:33.
Michael Ulbricht schrieb:
das sind Flickr-Bilder […] Die Leerzeile wird der [DSO-]Forensoftware eingefügt
Habe ich das dann richtig verstanden und zusammengefasst [www.drehscheibe-online.de]?


Walter
Mikado-Freund schrieb:
Habe ich das dann richtig verstanden und zusammengefasst [www.drehscheibe-online.de]?

äh, ja! Oder einfacher gesagt: Wenn man den von Flickr generierten BB-Code in einen DSO-Beitrag kopiert, wird das korrekt angezeigt (jetzt übrigens auch im neuen Editor) und wenn man das kürzt oder selber nur den Bildlink einzeln verwendet, muss man auf den Zeilenumbruch achten.

Grüße, -mu 

gelöst: Das Rätsel mit den Leerzeichen!

geschrieben von: Michael Ulbricht

Datum: 21.12.17 22:07

Mikado-Freund schrieb:Zitat:
  • unnötiger Entfall der Leerzeichenmehrfachanschlag-Unterdrückung (Unterdrückung des mehrfachen Anschlages von Leerzeichen) ▼

  • Hallo,

    ich habe lange gerätselt, denn es gibt in der ganzen Forensoftware gar keine "Mehrfachleerzeichen-Unterdrückung" - jetzt ist mir aber klar was passiert: Ein Browser zeigt Leerzeichen am Zeilenanfang und mehrfache Leerzeichen gar nicht an, da das auch ein Bestandteil der HTML-Formatierung sein könnte!
    Der alte Editor hat ein einfaches Texteingabefeld und darin können natürlich beliebig viele Leerzeichen in Folge enthalten sein, die werden aber im Beitrag hinterher vom Browser gar nicht angezeigt. Genauso ist es im neuen Editor in der Ansicht BBCODE. In der normalen Ansicht verwendet der Browser unter HTML5 automatisch ein geschütztes Leerzeichen, wenn mehrfach Leerzeichen in Folge eingegeben werden und das ist eigentlich auch korrekt, nur zur alten BB-Ansicht nicht kompatibel. Das geschützte Leerzeichen ist ein UTF-8 Zeichen, sowas gab es früher gar nicht, wir haben aber vor einiger Zeit die Forensoftware und die Datenbanken für die Verwendung internationaler Zeichen darauf angepasst.
    Damit sich der Editor in allen Ansicht gleich verhält, werden geschützte Leerzeichen jetzt durch normale Leerzeichen ersetzt. Das ist zwar eigentlich nicht korrekt, war aber früher nicht so ohne weiteres möglich.

    Grüße, -mu

    Re: gelöst: Das Rätsel mit den Leerzeichen!

    geschrieben von: Mikado-Freund

    Datum: 21.12.17 23:15

    Danke;

    das erklärt dann das Ergebnis meiner beiden Tests vom 25. [www.drehscheibe-online.de] und vom 29.10.17 [www.drehscheibe-online.de].


    Walter



    1-mal bearbeitet. Zuletzt am 2017:12:21:23:29:43.

    Statt Klammer zu nimmt er Klammer auf,

    geschrieben von: Go Fleiter

    Datum: 05.01.18 22:08

    statt Bindestrich nimmt er Schr'gstrich, statt aeh nimmt er ' (siehe Schr'gstrich!!), statt Klammer auf nimmt er *

    n'h n'h n'h

    und naeh naeh naeh kann er folglich auch nicht.

    Das ist unabh'ngig von BBCODE ein oder aus.
    Meine Tastatur geht im Windows [brigens richtig und nicht amerikanisch.
    LG! Go

    Schöne Grüße aus Düsseldorf! Go
    Die Links zu unserer Anlage Fleiter- Pempelforth:

    [www.drehscheibe-online.de]

    Inhaltsverzeichnis von "Peter" mit Links zu Bau-, Anlagen-, Lackier- und anderen Beiträgen von weiteren Autoren:
    [www.drehscheibe-online.de]




    1-mal bearbeitet. Zuletzt am 05.01.18 22:09.

    Re: Statt Klammer zu nimmt er Klammer auf …

    geschrieben von: Mikado-Freund

    Datum: 05.01.18 22:55

    Hallo 'Go',

    auch wenn Du schreibst »Meine Tastatur geht im Windows [brigens richtig und nicht amerikanisch« —
    in erster Näherung „riecht“ das aber doch nach verstellter Tastatur [www.tastatur-taste.de]:

    http://vig-wirkt-nicht.de/wp-content/uploads/2016/08/englische-tastatur.jpg

    Achte mal auf die Lage der öffnenden eckigen Klammer „[“ in der englischen ▲ -
    und auf die des Buchstabens „Ü“ ▼ in der deutschen Tastaturbelegung.

    http://vig-wirkt-nicht.de/wp-content/uploads/2016/09/tastatur-keyboard-kbd-itwissen-computer-tastatur-deutsch-computer-tastatur-deutsch.png

    Re: Statt Klammer zu nimmt er Klammer auf …

    geschrieben von: Provodnik

    Datum: 07.01.18 21:18

    Zwei Anmerkungen/Wünsche zum neuen Editor:

    - es ist fein, dass man jetzt youtube.-Videos direkt in einen Beitrag einbinden kann. Fein wäre aber auch, wenn man deren angezeigte maximale Breiste justieren könnte. Jetzt ist die Anzeigebreite = Bildschirmbreite, also oft viel zu gross.

    - manchmal, wenn man mit Strg+V irgendwo im Beitrag etwas einfügt, springt der Editor ans Ende des gerade in Verfassung befindlichen Beitrages. Ich hab bisher aber noch nicht rausgefunden, in welchen Fällen der Editor dann (mit dem Cursor) ganz nach unten springt... es ist irgendwie erratisch. Das ist jedenfalls nervig. Kann man das abstellen?


    Provodnik
    Provodnik schrieb:
    es ist fein, dass man jetzt Youtube-Videos direkt in einen Beitrag einbinden kann. Fein wäre aber auch, wenn man deren angezeigte maximale Breiste justieren könnte.
    Jetzt ist Anzeigebreite = Bildschirmbreite, also oft viel zu groß.
    Dieses Problem ist deutlich älter als die Einführung des neuen Editors, denn es existiert bereits seit der Einführung des BB-Codes „Video“ im Mai 2016 [www.drehscheibe-online.de], hat damit also gar nichts zu tun. Der Administration ist es jedenfalls durchaus bekannt [www.drehscheibe-online.de] ff.

    Offensichtlich »überstimmt« die Forensoftware die im »Einbetten-Link« enthaltenen Höhen- und Breitenangaben „width=…“ und „height=…“ [www.html-seminar.de].

    Von mir empfohlene Lösung: schalte in die alte Ansicht um.





    3-mal bearbeitet. Zuletzt am 08.01.18 00:32.
    Mikado-Freund schrieb:
    Provodnik schrieb:
    es ist fein, dass man jetzt Youtube-Videos direkt in einen Beitrag einbinden kann. Fein wäre aber auch, wenn man deren angezeigte maximale Breiste justieren könnte.
    Jetzt ist Anzeigebreite = Bildschirmbreite, also oft viel zu groß.
    Dieses Problem ist deutlich älter als die Einführung des neuen Editors, denn es existiert bereits seit der Einführung des BB-Codes „Video“ im Mai 2016 [www.drehscheibe-online.de], hat damit also gar nichts zu tun. Der Administration ist es jedenfalls durchaus bekannt [www.drehscheibe-online.de] ff.

    Offensichtlich »überstimmt« die Forensoftware die im »Einbetten-Link« enthaltenen Höhen- und Breitenangaben „width=…“ und „height=…“ [www.html-seminar.de].

    Von mir empfohlene Lösung: schalte in die alte Ansicht um.
    genau so ist es! Neu ist nur die Unterstützung für das Einbinden von Videos mit einem Button. Absolute Größenangaben sind bei einer geräteunabhängigen Darstellung völlig Widersinnig. Man könnte das bestenfalls bei großen Displays auf z.B. die halbe Breite begrenzen. Aber warum Mäusekino, wenn auch Breitwand geht?

    Die alte Ansicht ist natürlich die beste Lösung, weil dort ohne den Button niemand auf die Idee kommt Videos einzubetten, die in der alten Ansicht für einen Teil der Nutzer sowieso nicht darstellbar sind ...

    Grüße, -mu
    Michael Ulbricht schrieb:
    Neu ist nur die Unterstützung für das Einbinden von Videos mit einem Button.
    Absolute Größenangaben sind bei einer geräteunabhängigen Darstellung völlig widersinnig.
    Nun ist das Thema dieses Fadens ja eigentlich™ der neue Eidor und nicht die neue Ansicht, aber sei’s drum, denn beim Satz zwei erhebe ich Einspruch!

    Warum muss man (sich) denn mit aller Gewalt ein Video im Vollbildmodus anzeigen (lassen)?

    Man schaue sich bitte mal nachfolgende Hardcopy an — grausam; mehr fällt mir dazu nicht ein! ▼


    Video geringer Aufloesung und dessen erzwungene Anzeige im Volllbildmodus in der mobilgeraetetauglichen Ansicht.jpg




    Michael Ulbricht schrieb:
    Man könnte das bestenfalls bei großen Displays auf z.B. die halbe Breite begrenzen.
    Aber warum Mäusekino, wenn auch Breitwand geht?
    Antwort siehe oben: weil es Videos gibt, deren Anpassung an den möglicherweise „viel zu großen“ Bildschirm völlig sinnlos ist — zumindest habe ich 'Provodnik' so verstanden.



    Michael Ulbricht schrieb:
    Die alte Ansicht ist natürlich die beste Lösung, weil dort ohne den Button niemand auf die Idee kommt Videos einzubetten, die in der alten Ansicht für einen Teil der Nutzer sowieso nicht darstellbar sind …
    Das verstehe ich nicht.

    Warum soll in der alten Ansicht niemand auf die Idee kommen, ein Video einzubinden und für wen sollen die dann nicht darstellbar sein? ▼

    Video-Quellseite.jpg

    (mit „Vollbildmodus“ ist hier nicht das angezeigte Video - sondern der Browser nach einem Druck auf die Taste „F 11“ gemeint)



    Völlig problemlos in alter Ansicht mit den Video-BB-Codes eingebettetes - und anschließend angezeigtes Video: ▼

    Video,_alte-Ansicht.jpg




    Wenn man das unbedingt möchte, dann kann man sich das Video nach meiner bisherigen Kenntnis selbstverständlich auch in der alten Ansicht im Vollbildmodus anzeigen lassen: ▼

    Video im Vollbildmodus, Button angeklickt in der alten Ansicht!.jpg







    Gruß

    Walter



    1-mal bearbeitet. Zuletzt am 08.01.18 20:18.
    Hallo,

    Früher war alles viel besser, da gab es nur Monitore mit einer Auflösung von 640 x 480 Pixeln und jeder hatte sowas. Die Zeiten sind zum Glück vorbei, ich nutze DSO inzwischen auf etwa 7 bis 8 unterschiedlichen Geräten, allerdings hat jedes davon auch eine andere Auflösung.

    In der alten Ansicht, die auf etwa 800 Pixel in der Breite optimiert war, sehen Videos recht brauchbar aus, auf größeren Displays wird draus allerdings schnell ein "Mäusekino", während es auf Mobilgeräten den Rahmen sprengt, wie auch übergroße Fotos. In der neuen Ansicht, sieht das auf allen meinen Geräte gleich brauchbar aus und genau das ist ja auch der Sinn einer geräteunabhängigen Darstellung. Im Detail kann man das sicher noch weiter optimieren, ich hatte auch schon an einen entsprechenden Rand bzw. Hintergrund gedacht, mit dem Videos auf größeren Displays vielleicht etwas gefälliger aussehen.

    Anders als bei Fotos, die eine definierte Höhe und Breite in Pixeln haben, kann man aus einem Video-Link von YouTube nicht auf die Größe schließen, man kann nur eine relative Größe bezogen auf die Ansicht des Beitrags festlegen.

    Wir haben hier aus dem angepinnten Beitrag zum Thema Videos ein schönes Beispiel:
    [www.drehscheibe-online.de]
    Das sieht bei mir in der neuen "Breitwand"-Ansicht sehr gut aus, ebenso das Video mit der Baureihe 96 (einfach bei YouTube nach diesem Stichwort suchen). Allerdings verwende ich bei 1920 Pixeln in der Breite auch die seitliche Navigation, die ganze Variantenvielfalt ist aber noch mal ein Thema für sich ...

    Grüße, Michael
    Hallo,

    bei längeren Beiträgen muss ich immer noch damit rechnen, dass ich irgendwann "blind" schreiben muss, weil der Editoransicht nach oben springt!
    User die nur drei Zeilen schreiben, werden das nicht kennen.

    Ich muss also praktisch den Beitrag von unten nach oben schreiben, oder Textblöcke nach unten verschieben, damit der Editor mir die Ansicht gewährt.

    Oder alles bei Word schreiben und dann hineinkopieren. Ist das gewünscht?

    Wenn ich Bilder oder Textblöcke nachträglich zentriere, dann sieht man im Forumsbeitrag Zentrierzeichen, wie [i .... [/i].
    Diese lassen sich im Editor aber nicht mehr, wie früher, entfernen.

    Über [BBCODE] kommen ich nicht zum BBCODE. Bei anderen scheint das aber zu funktionieren...

    Gruß, Ulrich :-(



    1-mal bearbeitet. Zuletzt am 16.01.18 16:26.
    Oh Gott...

    TransLog schrieb:
    dass ich irgendwann "blind" schreiben muss, [...] User die nur drei Zeilen schreiben, werden das nicht kennen.

    (verkneife mir einen fiesen Kommentar über Leute mit Facebook und/oder Digitalzentrale)

    TransLog schrieb:
    Oder alles bei Word schreiben und dann hineinkopieren.

    Das war m.M.n. schon immer die beste Methode, einen Forenbeitrag zu schreiben (nicht nur hier). Nimm lieber einen Text-Editor, das geht schneller. Stelle außerdem Deine Tastatur auf US-Englisch um, Dann wird BB-Code einfacher.

    Noch besser: Lösche Deine Browsergeschichte, und klicke beim nächsten Besuch auf "alte Version". Dann ist der Spuk vorbei.



    1-mal bearbeitet. Zuletzt am 16.01.18 17:05.

    Folgender Text ist in [BBCODE] geschrieben...

    geschrieben von: TransLog

    Datum: 17.01.18 10:16

    Hallo,

    heute schreibe ich Euch mal in BBCODE

    Gruß, Ulrich

    P.S. Sieht so BBCODE aus?

    Ich benutze allerdings noch Windows 7

    Braucht man für den neuen Editor Windows 10 (OMG Edition) ?

    Win 7 und IE

    geschrieben von: Michael Ulbricht

    Datum: 17.01.18 12:28

    TransLog schrieb:
    Ich benutze allerdings noch Windows 7

    Braucht man für den neuen Editor Windows 10 (OMG Edition) ?
    man benötigt einen Bowser der HTML5 unterstützt und das ist mit dem alten IE unter Win 7 nicht gegeben. Mit Firefox oder Chrome sollte aber alles funktionieren, ebenso mit IE 11 unter Win 8. Mit älteren Versionen hat man aber nicht nur bei DSO Probleme ...

    Ergänzung: IE 11 unter Win 7 funktioniert natürlich auch! Der IE verhält sich aber etwas eigenwillig und unter Win 10 wieder anders. Unter XP funktioniert nur Firefox und wer soweit zurück ist, kann über die Startseite auch auf die "alte Ansicht" umschalten.

    Re: Text ist in [BBCODE] geschrieben

    geschrieben von: Mikado-Freund

    Datum: 17.01.18 17:33

    TransLog schrieb:
    heute schreibe ich Euch mal in BBCODE
    P.S. Sieht so BBCODE aus?
    Das kann man nicht wissen, weil man ja nicht sehen kann, wie Du was eingegeben hast, bzw. was Du an dieser Stelle meinst: evtl. von Dir eingegebene Steuerbefehle werden nach dem Absenden vom Foreninterpreter erkannt und umgesetzt - und dann natürlich nicht mehr angezeigt!

    Damit man aber das sehen kann, was Du zeigen willst, solltest Du vorm Absenden mal einen Bildschirmausdruck anfertigen und den dann einstellen.


    Zitat
    Ich benutze allerdings noch Windows 7
    Das ist kein Problem; dieses Betriebssystem benutze ich in der 64 bit-Version ebenfalls (it’s a running system!).


    Zitat
    Braucht man für den neuen Editor Windows 10?
    Wie es in der Antwort zuvor schon angeklungen ist, es ist nicht das Betriebssystem - sondern der Browser maßgeblich.
    Sofern Du IE-Nutzer bist und falls Du diesen (noch) nicht in die Version 11 überführt haben solltest: „mach et“; anders als man es aus der vorherigen Antwort schließen könnte, läuft der nämlich auch schon unter Win 7 …!



    Walter
    Michael Ulbricht schrieb:
    […] in der "alten Ansicht", über die man auf der Startseite umschalten kann, ist alles unverändert.
    Ich hatte versehentlich die Buttons im alten Editor deaktiviert, aber die funktionieren jetzt wieder.
    Hinweis

    Es funktionieren erneut einige Schaltflächen des alten Editors nicht mehr:
    alter-Editor-setzt-Steuerbefehle-nicht-mehr-um — warum¿.jpg



    Hiermit bitte ich höflich um deren Reanimation; insbesondere immer dann, wenn man Beiträge editieren - und dabei die Vorschau benutzen muss, haben die im alten Editor permanent angezeigten BB-Codes (zumindest in meinen Augen) doch erhebliche Vorteile …!




    Walter



    1-mal bearbeitet. Zuletzt am 05.02.18 22:57.
    Mikado-Freund schrieb:
    Es funktionieren erneut einige Schaltflächen des alten Editors nicht mehr:
    Hallo,

    es wurde "erneut" in den letzten vier Wochen überhaupt nichts geändert und am alten Editor schon gar nicht!
    kleine Fußnoten funktionieren nach wie vor mit altem und neuem Editor ...

    Gruß, -mu
    Michael Ulbricht schrieb:
    es wurde "erneut" in den letzten vier Wochen überhaupt nichts geändert und am alten Editor schon gar nicht
    Danke für Deine Antwort.

    Den gestern Abend auf einem Win 7 64-Bit-Rechner unter aktuellem 64-Bit-Firefox angefertigten Screenshot habe ich mir aber nicht ausgedacht — und zum »erneut deaktiviert« — es hätte doch durchaus sein können, dass (vielleicht ja sogar auch nur versehentlich) irgend etwas im alten Editor abgeschaltet wurde …!


    Ich habe mir daraufhin mein gestriges Posting noch einmal auf zwei anderen Rechnern angesehen (Betriebssysteme jeweils Win 7 und XP, beide in 32-Bit-Version. Als Browser kamen auf dem Win 7-Rechner der IE 11 - und auf dem XP_Rechner der aktuelle Firefox zum Einsatz.

    Siehe da; auf beiden Rechnern - und unter beiden Browsern sind die Befehle zur Schriftgröße in beiden Ansichtseinstellungen umgesetzt worden. ▼

    alte Ansicht, XP und Firefox.jpg



    Das hat mir natürlich keine Ruhe gelassen, weshalb ich mir fragliches Posting erneut auf dem 64-Bit-Rechner angeschaut habe: ▼

    alter-Editor-setzt-Steuerbefehl(e)-nicht-um. Browser-ist-Firefox-64-bit.jpg

    Fazit: offensichtlich ist danach also der aktuelle 64-Bit-Firefox-Browser der Verursacher der Fehlfunktion. ▲



    Walter



    2-mal bearbeitet. Zuletzt am 06.02.18 18:53.

    Seiten: 1 ... 5 6 7 8 9 10 11 12 13 14 15

    Angemeldet: -